Un error común en Debian 11 al instalar algún software es la falta de la librería libappindicator3-1, me ha pasado con Binance y con Slack, esta librería ha sido sustituida por otra, sin embargo, algunas aplicaciones siguen necesitando la original, sino no se instalan, por ejemplo dando el siguiente error:

alvaro@desktop:~$ sudo dpkg -i Descargas/binance-amd64-linux.deb 
Seleccionando el paquete binance previamente no seleccionado.
(Leyendo la base de datos ... 242665 ficheros o directorios instalados actualmente.)
Preparando para desempaquetar .../binance-amd64-linux.deb ...
Desempaquetando binance (1.26.1) ...
dpkg: problemas de dependencias impiden la configuración de binance:
 binance depende de libappindicator3-1; sin embargo:
  El paquete `libappindicator3-1' no está instalado.

dpkg: error al procesar el paquete binance (--install):
 problemas de dependencias - se deja sin configurar
Procesando disparadores para hicolor-icon-theme (0.17-2) ...
Procesando disparadores para gnome-menus (3.36.0-1) ...
Procesando disparadores para desktop-file-utils (0.26-1) ...
Procesando disparadores para mailcap (3.69) ...
Se encontraron errores al procesar:
 binance

Las librerías que necesitamos podemos encontrarlo en los repositorios de Buster, la versión anterior de Debian, podemos verlo en los siguientes enlaces:

https://packages.debian.org/buster/libindicator3-7
https://packages.debian.org/buster/libappindicator3-1

Por ejemplo podemos utilizar estos enlaces:

wget http://ftp.us.debian.org/debian/pool/main/libi/libindicator/libindicator3-7_0.5.0-4_amd64.deb
wget http://ftp.us.debian.org/debian/pool/main/liba/libappindicator/libappindicator3-1_0.4.92-7_amd64.deb

Una vez que lo descarguemos:

sudo apt install ./libindicator3-7_0.5.0-4_amd64.deb
sudo apt install ./libappindicator3-1_0.4.92-7_amd64.deb

Luego podemos volver a intentar instalar el software que nos dio el error de dependencias.

Deja una respuesta

Tu dirección de correo electrónico no será publicada.