Actualizar de MariaDB 5.5 a MariaDB 10 en CentOS 7

En una instalación por defecto CentOS nos ofrece MariaDB 5.5 y puede que se necesite instalar una versión más actual por alguna funcionalidad, por algún requerimiento o por la razón que sea. Al menos que se esté seguro que la base de datos y las aplicaciones que usen esas base de datos soportan el cambio conviene que el cambio sea evaluado. Se tiene que tener presente que luego del update

Actualización del contenedor CentOS7 [Febrero 2019]

Esto es una actualización de la imagen utilizada en Crear contenedor Docker con CentOS 7 para crear un entorno e instalar todo lo que necesitemos. Si te interesa un entorno PHP + Nginx ya preconfigurado te recomiendo Crear contenedor Docker con CentOS7/Nginx/MariaDB y MultiPHP A nivel de software no hay grandes campos solo se actualizaron paquetes de sistema y de servicios, una lista completa de los paquetes actualizados:

Actualización CentOS7/Nginx/MariaDB [Febrero 2019]

Esto es una actualización de la imagen utilizada en Crear contenedor Docker con CentOS7/Nginx/MariaDB y MultiPHP para crear un entorno de desarrollo ideal para PHP. A nivel de software no hay grandes campos solo se actualizaron paquetes de sistema y de servicios, una lista completa de los paquetes actualizados:

Problemas con Docker al reinicar servicios: Failed to get D-Bus connection: Operation not permitted

Unos de los primeros problemas que encontre con Docker es que cuando queria iniciar servicios en un sistema que utilizara systemd en lugar del viejo init.d daba el siguiente error: [root@e8c87e7efdd4 /]# systemctl start httpd Failed to get D-Bus connection: Operation not permitted [root@e8c87e7efdd4 /]#   Para solucionarlo primero ejecutamos: [root@4505f0166db1 /]# yum update -y && yum install -y initscripts Eso nos dara una salida de todos los paquetes que