Una de las actividades mas importantes de un administrador de sistemas a parte de realizar backups y atender idiotas es mantener la seguridad de todos sistemas, eso implica por un lado mantener actualizado y parches al día en todos sistemas aunque por mas actualizado que este puede ser vulnerable tanto por una mala configuración como por una versión de algún servicio con alguna vulnerabilidad conocida.

Una de las grandes herramientas para mantener la seguridad y encontrar problemas realizando auditorias de seguridad es OpenVAS y una vulnerabilidad en los reportes que no es tal es cuando realizamos un scan con OpenVAS podemos llegar a ver en la lista de vulnerabilidades el siguiente mensaje:

Report outdated / end-of-life scan engine / environment (local)

Al principio puede resultar confuso sin emabrgo no es una vulnerabilidad del servidor objetivo sino del propio scanner, lo que nos esta diciendo es que la versión instalado es vieja, eso aunque tengamos el sistema actualizado.

Es especialmente molesto porque esto lo agrega a los reportes como vulnerabilidad cuando no se trata de una vulnerabilidad del objetivo sino del propio scanner, debería avisas si, solo que no en los reportes.

Lo ideal seria descargar versión mas actualizada sin embargo eso implica compilar y configurar un montón de paquetes por separado.

La solución no tan ideal aunque si mas sencilla es hacer que OpenVAS considere las versiones instaladas como actualizadas, para ello solo tenemos que modificar el archivos gb_outdated_scan_engine.nasl y modificar el numero de versión que OpenVAS considera actualizado.

Para ello, editamos el archivo:

/var/lib/openvas/plugins/gcf/gb_outdated_scan_engine.nasl

Alli encontramos algo como esto:

expected_gce_ver = “6.0.7”;
expected_libs_ver1 = “10.0.2”;
expected_libs_ver2 = “11.0.1”;

Y remplazamos por versión anteriores, por ejemplo en mi caso tengo la 9.0.3 asi que configuro esa, lo dejamos algo similar a esto según las versiones que correspondan con nuestra instalación

expected_gce_ver = “5.1.3”;
expected_libs_ver1 = “9.0.3”;
expected_libs_ver2 = “9.0.3”;

Luego guardamos los cambios, salimos y ejecutamos:

openvas-stop
openvas-start

Con eso ya podremos correr los scan sin que agregue el dichos mensaje a los reportes.

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *