Podemos llegar a tener la necesidad de incluir algo modulo o extension que por defecto no viene incluido y por eso para evitar recompliclar PHP completo, supongamos que queremos habilitar soporte para hilos, para eso necesitamos compilar el módulo **pcntl**

Primero debemos determinar que versión de PHP tenemos, para eso hacemos

php -m
or
php-fpm -m

Una vez que lo sepamos vamos a http://www.php.net/releases/ y nos descargamos la version que tengamos ya instalada, por ejemplo supongamos que descargamos php-7.0.31.tar.gz

tar -xzvf php-7.0.31.tar.gz

#Buscamos la carpeta del módulo que queramos compilar
cd php-7.0.31/ext/pcntl/

#Ejecutamos
phpize

#Luego
./configure

#Y por ultimo
make

#Si listamos la carpeta modules veremos que se creo
#correctamente el modulo pcntl.so
[root@server pcntl]# ls -lh modules/
total 100K
-rw-r--r--. 1 root root 907 Dec  5 05:02 pcntl.la
-rwxr-xr-x. 1 root root 95K Dec  5 05:02 pcntl.so

#Esta ruta puede cambiar en su instalacion asi que 
#deberan buscarlo, en mi caso la carpeta de módulos 
#se encuentra en:
/opt/remi/php71/root/usr/lib64/php/modules/

cp modules/pcntl.so /opt/remi/php71/root/usr/lib64/php/modules/

#Buscamos el archivo INI
#Esto puede no ser igual en tu PC
#en mi caso esta en
/etc/opt/remi/php71/php.ini 

#Y lo agremos
echo "extension=pcntl.so" >> /etc/opt/remi/php71/php.ini 

Si usamos php-fpm debemos reiniciarlo

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *